USN-1728-1: Linux kernel (EC2) vulnerability

19 February 2013

The system could be made to crash under certain conditions.

Releases

Packages

Details

Andrew Cooper of Citrix reported a Xen stack corruption in the Linux
kernel. An unprivileged user in a 32bit PVOPS guest can cause the guest
kernel to crash, or operate erroneously.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

Related notices

  • USN-1719-1: linux-image-3.0.0-31-virtual, linux-image-3.0.0-31-server, linux-lts-backport-oneiric, linux-image-3.0.0-31-generic, linux-image-3.0.0-31-generic-pae
  • USN-1720-1: linux-image-3.0.0-31-virtual, linux-image-3.0.0-31-server, linux-image-3.0.0-31-generic, linux-image-3.0.0-31-generic-pae, linux-image-3.0.0-31-powerpc-smp, linux-image-3.0.0-31-powerpc, linux, linux-image-3.0.0-31-powerpc64-smp, linux-image-3.0.0-31-omap
  • USN-1725-1: linux-image-2.6.32-45-generic-pae, linux-image-2.6.32-45-ia64, linux-image-2.6.32-45-versatile, linux-image-2.6.32-45-virtual, linux-image-2.6.32-45-lpia, linux-image-2.6.32-45-sparc64, linux-image-2.6.32-45-sparc64-smp, linux-image-2.6.32-45-preempt, linux-image-2.6.32-45-generic, linux-image-2.6.32-45-server, linux-image-2.6.32-45-powerpc-smp, linux-image-2.6.32-45-powerpc64-smp, linux-image-2.6.32-45-386, linux-image-2.6.32-45-powerpc, linux
  • USN-1767-1: linux-image-3.2.0-39-highbank, linux-image-3.2.0-39-generic, linux-image-3.2.0-39-generic-pae, linux-image-3.2.0-39-omap, linux-image-3.2.0-39-powerpc-smp, linux-image-3.2.0-39-virtual, linux, linux-image-3.2.0-39-powerpc64-smp
  • USN-1768-1: linux-image-3.5.0-26-generic, linux-lts-quantal
  • USN-1769-1: linux-image-3.5.0-26-omap, linux-image-3.5.0-26-powerpc-smp, linux, linux-image-3.5.0-26-powerpc64-smp, linux-image-3.5.0-26-highbank, linux-image-3.5.0-26-generic
  • USN-1774-1: linux-ti-omap4, linux-image-3.5.0-221-omap4