Your submission was sent successfully! Close

USN-1443-1: Update Manager vulnerabilities

17 May 2012

Update Manager could expose sensitive information in certain circumstances.

Releases

Packages

Details

It was discovered that Update Manager created system state archive files
with incorrect permissions when upgrading releases. A local user could
possibly use this to read repository credentials. (CVE-2012-0948)

Felix Geyer discovered that the Update Manager Apport hook incorrectly
uploaded certain system state archive files to Launchpad when reporting
bugs. This could possibly result in repository credentials being included
in public bug reports. (CVE-2012-0949)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.04
Ubuntu 11.10
Ubuntu 11.04

In general, a standard system update will make all the necessary changes.