Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-6931

Published: 19 December 2023

A heap out-of-bounds write vulnerability in the Linux kernel's Performance Events system component can be exploited to achieve local privilege escalation. A perf_event's read_size can overflow, leading to an heap out-of-bounds increment or write in perf_read_group(). We recommend upgrading past commit 382c27f4ed28f803b1f1473ac2d8db0afc795a1b.

From the Ubuntu Security Team

Budimir Markovic, Lucas De Marchi, and Pengfei Xu discovered that the perf subsystem in the Linux kernel did not properly validate all event sizes when attaching new events, leading to an out-of-bounds write vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code.

Notes

AuthorNote
Priority reason:
On 4.4 kernels, it is still possible to use perf_event_open by default for software events.
sbeattie
7e2c1e4b34f0 ("perf: Fix perf_event_validate_size()
lockdep splat") is a followup lockdep fix for 382c27f4ed28 ("perf:
Fix perf_event_validate_size()")

Priority

High

Cvss 3 Severity Score

7.0

Score breakdown

Status

Package Release Status
linux-hwe
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Ignored
(replaced by linux-hwe-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

xenial
Released (4.15.0-221.232~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

upstream
Released (6.7~rc6)
linux-hwe-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

bionic
Released (5.4.0-170.188~18.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

upstream
Released (6.7~rc6)
linux-hwe-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-hwe-5.11)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-hwe-5.11)
noble Does not exist

linux-hwe-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-hwe-5.13)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-hwe-5.13)
noble Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-hwe-5.15)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-hwe-5.15)
noble Does not exist

linux-hwe-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-92.102~20.04.1)
noble Does not exist

upstream
Released (6.7~rc6)
linux-hwe-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-hwe-6.2)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-hwe-6.2)
noble Does not exist

linux-hwe-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy Ignored
(superseded by linux-hwe-6.5, was needed)
upstream Ignored
(superseded by linux-hwe-6.5, was needed)
noble Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Ignored
(superseded by linux-hwe)
bionic Ignored
(superseded by linux-hwe-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

trusty
Released (4.4.0-250.284~14.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

upstream
Released (6.7~rc6)
linux-kvm
Launchpad, Ubuntu, Debian
trusty Does not exist

mantic Does not exist

focal
Released (5.4.0-1105.112)
jammy
Released (5.15.0-1049.54)
lunar Ignored
(end of life, was needed)
bionic
Released (4.15.0-1148.153)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (4.4.0-1128.138)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

upstream
Released (6.7~rc6)
linux-allwinner
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Ignored
(end of kernel support)
mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-allwinner-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(end of kernel support)
lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-aws-5.0
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-hwe-5.3)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-hwe-5.3)
noble Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-aws-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-aws-5.4)
noble Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream
Released (6.7~rc6)
bionic
Released (5.4.0-1117.127~18.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

linux-aws-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-aws-5.11)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-aws-5.11)
noble Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-aws-5.13)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-aws-5.13)
noble Does not exist

linux-aws-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-aws-5.15)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-aws-5.15)
noble Does not exist

linux-aws-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1052.57~20.04.1)
upstream
Released (6.7~rc6)
noble Does not exist

linux-aws-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-aws-6.2)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-aws-6.2)
noble Does not exist

linux-aws-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (6.2.0-1018.18~22.04.1)
upstream Ignored
(superseded by linux-aws-6.5, was needed)
noble Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream
Released (6.7~rc6)
xenial
Released (4.15.0-1164.177~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

linux-azure
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.3)
jammy
Released (5.15.0-1054.62)
lunar Ignored
(end of life, was needed)
mantic
Released (6.5.0-1011.11)
trusty
Released (4.15.0-1173.188~14.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (6.7~rc6)
xenial
Released (4.15.0-1173.188~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
focal
Released (5.4.0-1122.129)
noble Pending

linux-azure-4.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

bionic
Released (4.15.0-1173.188)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (6.7~rc6)
noble Does not exist

linux-azure-5.3
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-azure-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-5.4)
noble Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

bionic
Released (5.4.0-1122.129~18.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (6.7~rc6)
noble Does not exist

linux-azure-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-azure-5.11)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-5.11)
noble Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-azure-5.13)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-5.13)
noble Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-azure-5.15)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-5.15)
noble Does not exist

linux-azure-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1054.62~20.04.1)
upstream
Released (6.7~rc6)
noble Does not exist

linux-azure-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-azure-6.2)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-6.2)
noble Does not exist

linux-azure-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (6.2.0-1019.19~22.04.1)
upstream Ignored
(superseded by linux-azure-6.5, was needed)
noble Does not exist

linux-azure-fde
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-azure-fde-5.15)
lunar Does not exist

mantic Does not exist

jammy
Released (5.15.0-1054.62)
upstream
Released (6.7~rc6)
noble Does not exist

linux-azure-fde-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1054.62~20.04.1)
upstream
Released (6.7~rc6)
noble Does not exist

linux-azure-fde-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-azure-fde-6.2)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-fde-6.2)
noble Does not exist

linux-azure-fde-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (6.2.0-1019.19~22.04.1.1)
upstream Ignored
(replaced by linux-azure-6.5, was needed)
noble Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.4.0-1077.83)
jammy
Released (5.15.0-1033.35)
upstream
Released (6.7~rc6)
noble Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(end of standard support)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-azure-5.3)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-5.3)
noble Does not exist

linux-fips
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Ignored
(end of standard support)
bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream
Released (6.7~rc6)
noble Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Ignored
(superseded by linux-gcp-5.3)
focal
Released (5.4.0-1121.130)
jammy
Released (5.15.0-1049.57)
lunar Ignored
(end of life, was needed)
mantic
Released (6.5.0-1011.11)
upstream
Released (6.7~rc6)
xenial
Released (4.15.0-1158.175~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Pending

linux-gcp-4.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream
Released (6.7~rc6)
bionic
Released (4.15.0-1158.175)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-gcp-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gcp-5.4)
noble Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

bionic
Released (5.4.0-1121.130~18.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

upstream
Released (6.7~rc6)
linux-gcp-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-gcp-5.11)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gcp-5.11)
noble Does not exist

linux-gcp-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-gcp-5.13)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gcp-5.13)
noble Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-gcp-5.15)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gcp-5.15)
noble Does not exist

linux-gcp-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1049.57~20.04.1)
noble Does not exist

upstream
Released (6.7~rc6)
linux-gcp-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-gcp-6.2)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gcp-6.2, was needed)
noble Does not exist

linux-gcp-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (6.2.0-1021.23~22.04.1)
upstream Ignored
(superseded by linux-gcp-6.5, was needed)
noble Does not exist

linux-gke
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Ignored
(end of standard support)
bionic Does not exist

focal Ignored
(end of kernel support)
lunar Does not exist

mantic Does not exist

jammy
Released (5.15.0-1049.54)
noble Not vulnerable

upstream
Released (6.7~rc6)
linux-gke-4.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-gke-5.0)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gke-5.0)
noble Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-gke-5.3)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gke-5.3)
noble Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-gke-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-gke-5.4)
noble Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(end of kernel support)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-gke-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(end of kernel support)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (5.15.0-1035.41)
focal
Released (5.4.0-1084.88)
upstream
Released (6.7~rc6)
noble Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(end of kernel support)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-gkeop-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1035.41~20.04.1)
noble Does not exist

upstream
Released (6.7~rc6)
linux-ibm
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy
Released (5.15.0-1045.48)
lunar Ignored
(end of kernel support, was needs-triage)
mantic Ignored
(end of kernel support, was needs-triage)
focal
Released (5.4.0-1064.69)
noble Pending

upstream
Released (6.7~rc6)
linux-ibm-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

bionic
Released (5.4.0-1064.69~18.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

upstream
Released (6.7~rc6)
linux-ibm-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1045.48~20.04.1)
noble Does not exist

upstream
Released (6.7~rc6)
linux-intel-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(end of kernel support)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-intel-iotg
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (5.15.0-1047.53)
noble Does not exist

upstream
Released (6.7~rc6)
linux-intel-iotg-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1048.54~20.04.1)
noble Does not exist

upstream
Released (6.7~rc6)
linux-iot
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.4.0-1029.30)
noble Does not exist

upstream
Released (6.7~rc6)
linux-laptop
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic
Released (6.5.0-1008.11)
noble Does not exist

upstream
Released (6.7~rc6)
linux-lowlatency
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Ignored
(end of life, was needed)
mantic
Released (6.5.0-15.15.1)
jammy Pending
(5.15.0-92.102)
noble Pending

upstream
Released (6.7~rc6)
linux-lowlatency-hwe-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-92.102~20.04.1)
noble Does not exist

upstream
Released (6.7~rc6)
linux-lowlatency-hwe-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-lowlatency-hwe-6.2)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-lowlatency-hwe-6.2)
noble Does not exist

linux-lowlatency-hwe-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy Ignored
(superseded by linux-lowlatency-hwe-6.5, was needed)
upstream Ignored
(superseded by linux-lowlatency-hwe-6.5, was needed)
noble Does not exist

linux-nvidia
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (5.15.0-1043.43)
noble Not vulnerable

upstream
Released (6.7~rc6)
linux-nvidia-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (6.2.0-1015.15)
upstream Ignored
(superseded by linux-nvidia-6.5, was needed)
noble Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic
Released (4.15.0-1127.138)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
jammy
Released (5.15.0-1050.56)
lunar Ignored
(end of life, was needed)
focal
Released (5.4.0-1116.125)
xenial
Released (4.15.0-1127.138~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic
Released (6.5.0-1014.14)
noble Pending

upstream
Released (6.7~rc6)
linux-oracle-5.0
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-oracle-5.3)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oracle-5.3)
noble Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(superseded by linux-oracle-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oracle-5.4)
noble Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

bionic
Released (5.4.0-1116.125~18.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Does not exist

upstream
Released (6.7~rc6)
linux-oracle-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-oracle-5.11)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oracle-5.11)
noble Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-oracle-5.13)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oracle-5.13)
noble Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-oracle-5.15)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oracle-5.15)
noble Does not exist

linux-oracle-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1050.56~20.04.1)
noble Does not exist

upstream
Released (6.7~rc6)
linux-oem
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Ignored
(end of standard support)
bionic Ignored
(replaced by linux-hwe-5.4)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-oem-5.10)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oem-5.10)
noble Does not exist

linux-oem-5.10
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-oem-5.13)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oem-5.13)
noble Does not exist

linux-oem-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-oem-5.14)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oem-5.14)
noble Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(replaced by linux-hwe-5.15)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(replaced by linux-hwe-5.15)
noble Does not exist

linux-oem-5.17
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-oem-6.1)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oem-6.1)
noble Does not exist

linux-oem-6.0
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(superseded by linux-oem-6.1)
lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oem-6.1)
noble Does not exist

linux-oem-6.1
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oem-6.5, was needed)
jammy
Released (6.1.0-1029.29)
noble Does not exist

linux-oem-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy
Released (6.5.0-1013.14)
noble Does not exist

upstream
Released (6.7~rc6)
linux-oem-osp1
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(end of standard support)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy
Released (5.15.0-1045.48)
lunar Ignored
(end of life, was needed)
mantic
Released (6.5.0-1009.12)
upstream
Released (6.7~rc6)
focal
Released (5.4.0-1101.113)
noble Pending
(6.7.0-1001.1)
linux-raspi2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
focal Ignored
(replaced by linux-raspi)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(replaced by linux-raspi)
noble Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Ignored
(end of standard support)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-raspi2-5.4)
noble Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

bionic
Released (5.4.0-1101.113~18.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (6.7~rc6)
noble Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-riscv-5.8)
jammy Ignored
(end of kernel support)
lunar Ignored
(end of life, was needed)
mantic
Released (6.5.0-15.15.1)
upstream
Released (6.7~rc6)
noble Pending

linux-riscv-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-riscv-5.11)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-riscv-5.11)
noble Does not exist

linux-riscv-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(superseded by linux-riscv-5.13)
jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-riscv-5.13)
noble Does not exist

linux-riscv-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.15.0-1048.52~20.04.1)
upstream
Released (6.7~rc6)
noble Does not exist

linux-riscv-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(end of kernel support)
lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-snapdragon
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-starfive
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Ignored
(end of life, was needed)
mantic
Released (6.5.0-1006.7)
upstream
Released (6.7~rc6)
noble Does not exist

linux-starfive-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Ignored
(end of kernel support)
lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life)
noble Does not exist

linux-starfive-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

jammy Ignored
(superseded by linux-starfive-6.5, was needs-triage)
upstream Ignored
(superseded by linux-starfive-6.5, was needed)
noble Does not exist

linux-xilinx-zynqmp
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

lunar Does not exist

mantic Does not exist

focal
Released (5.4.0-1036.40)
upstream
Released (6.7~rc6)
jammy
Released (5.15.0-1027.31)
noble Does not exist

linux
Launchpad, Ubuntu, Debian
trusty Not vulnerable
(3.11.0-12.19)
upstream
Released (6.7~rc6)
jammy
Released (5.15.0-92.102)
lunar Ignored
(end of life, was pending [6.2.0-41.42])
bionic
Released (4.15.0-221.232)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
focal
Released (5.4.0-170.188)
xenial
Released (4.4.0-250.284)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic
Released (6.5.0-15.15)
noble Pending
(6.8.0-7.7)
Patches:
Introduced by

a723968c0ed36db676478c3d26078f13484fe01c

Fixed by 382c27f4ed28f803b1f1473ac2d8db0afc795a1b
Introduced by

382c27f4ed28f803b1f1473ac2d8db0afc795a1b

Fixed by 7e2c1e4b34f07d9aa8937fab88359d4a0fce468e
linux-aws
Launchpad, Ubuntu, Debian
jammy
Released (5.15.0-1052.57)
lunar Ignored
(end of life, was needed)
mantic
Released (6.5.0-1012.12)
upstream
Released (6.7~rc6)
bionic
Released (4.15.0-1164.177)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
focal
Released (5.4.0-1117.127)
trusty
Released (4.4.0-1127.133)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (4.4.0-1165.180)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
noble Pending

linux-hwe-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

upstream
Released (6.7~rc6)
jammy
Released (6.5.0-15.15~22.04.1)
noble Does not exist

linux-lowlatency-hwe-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

mantic Does not exist

upstream
Released (6.7~rc6)
jammy
Released (6.5.0-15.15.1.1~22.04.1)
noble Does not exist

linux-riscv-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

mantic Does not exist

upstream
Released (6.7~rc6)
noble Does not exist

jammy Not vulnerable
(6.5.0-17.17.1.1~22.04.1)
linux-starfive-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

mantic Does not exist

noble Does not exist

jammy Not vulnerable
(6.5.0-1007.8~22.04.1)
upstream
Released (6.7~rc6)
linux-aws-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Pending
(6.5.0-1012.12~22.04.1)
mantic Does not exist

upstream
Released (6.7~rc6)
noble Does not exist

linux-azure-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

mantic Does not exist

noble Does not exist

jammy Pending
(6.5.0-1011.11~22.04.1)
upstream
Released (6.7~rc6)
linux-gcp-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

mantic Does not exist

noble Does not exist

jammy Pending
(6.5.0-1011.11~22.04.1)
upstream
Released (6.7~rc6)
linux-oracle-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Pending
(6.5.0-1014.14~22.04.1)
mantic Does not exist

noble Does not exist

upstream
Released (6.7~rc6)
linux-nvidia-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

mantic Does not exist

noble Does not exist

upstream
Released (6.7~rc6)
linux-aws-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

linux-azure-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

linux-gcp-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

Severity score breakdown

Parameter Value
Base score 7.0
Attack vector Local
Attack complexity High
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H