Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-49441

Published: 6 June 2024

dnsmasq 2.9 is vulnerable to Integer Overflow via forward_query.

Notes

AuthorNote
Priority reason:
Per the Dnsmasq developer, this flaw has no practical effect

Priority

Low

Status

Package Release Status
dnsmasq
Launchpad, Ubuntu, Debian
bionic
Released (2.90-0ubuntu0.18.04.1+esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
focal
Released (2.90-0ubuntu0.20.04.1)
jammy
Released (2.90-0ubuntu0.22.04.1)
mantic Not vulnerable
(2.89-1)
noble Not vulnerable
(2.90-2ubuntu2)
trusty Needs triage

upstream
Released (2.89)
xenial
Released (2.90-0ubuntu0.16.04.1+esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
Patches:
upstream: https://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=65c2d6afd67a032f45f40d7e4d620f5d73e5f07d