Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-48161

Published: 22 November 2023

Buffer Overflow vulnerability in GifLib Project GifLib v.5.2.1 allows a local attacker to obtain sensitive information via the DumpSCreen2RGB function in gif2rgb.c

Notes

AuthorNote
Priority reason:
Is only a crash in a CLI tool
mdeslaur
one of the commits listes below likely fixes this issue.

Priority

Low

Cvss 3 Severity Score

7.1

Score breakdown

Status

Package Release Status
giflib
Launchpad, Ubuntu, Debian
bionic Needed

focal Needed

jammy Needed

lunar Ignored
(end of life, was deferred [2024-02-02])
mantic Needed

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Needed

Patches:
upstream: https://sourceforge.net/p/giflib/code/ci/fd0f408bd6dbc6ca33f0593d17164f9cb113a8ce/
upstream: https://sourceforge.net/p/giflib/code/ci/ccbc956432650734c91acb3fc88837f7b81267ff/

Severity score breakdown

Parameter Value
Base score 7.1
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H