Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-30636

Published: 2 July 2024

httpTokenCacheKey uses path.Base to extract the expected HTTP-01 token value to lookup in the DirCache implementation. On Windows, path.Base acts differently to filepath.Base, since Windows uses a different path separator (\ vs. /), allowing a user to provide a relative path, i.e. .well-known/acme-challenge/..\..\asd becomes ..\..\asd. The extracted path is then suffixed with +http-01, joined with the cache directory, and opened. Since the controlled path is suffixed with +http-01 before opening, the impact of this is significantly limited, since it only allows reading arbitrary files on the system if and only if they have this suffix.

Notes

AuthorNote
Priority reason:
Does not affect Ubuntu, only affects Go on Windows
mdeslaur
Packages built using golang need to be rebuilt once the
vulnerability has been fixed. This CVE entry does not
list packages that need rebuilding outside of the main
repository or the Ubuntu variants with PPA overlays.

Warning: do not include nullboot in the list of no-change
rebuilds after fixing an issue in golang.
alexmurray
Only affects golang on Windows so golang on Ubuntu is not affected

Priority

Low

Status

Package Release Status
golang
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
golang-1.10
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

trusty Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(Windows only)
golang-1.13
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(Windows only)
golang-1.14
Launchpad, Ubuntu, Debian
focal Not vulnerable
(Windows only)
jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
golang-1.16
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
golang-1.17
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Not vulnerable
(Windows only)
mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
golang-1.18
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(Windows only)
golang-1.19
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
golang-1.20
Launchpad, Ubuntu, Debian
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
noble Does not exist

upstream Not vulnerable
(Windows only)
golang-1.21
Launchpad, Ubuntu, Debian
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
noble Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
golang-1.22
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
noble Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
golang-1.6
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(Windows only)
golang-1.8
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)
golang-1.9
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Not vulnerable
(Windows only)