Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-25258

Published: 16 February 2022

An issue was discovered in drivers/usb/gadget/composite.c in the Linux kernel before 5.16.10. The USB Gadget subsystem lacks certain validation of interface OS descriptor requests (ones with a large array index and ones associated with NULL function pointer retrieval). Memory corruption might occur.

From the Ubuntu Security Team

It was discovered that the USB gadget subsystem in the Linux kernel did not properly validate interface descriptor requests. An attacker could possibly use this to cause a denial of service (system crash).

Priority

Medium

Cvss 3 Severity Score

4.6

Score breakdown

Status

Package Release Status
linux-nvidia
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

impish Does not exist

trusty Does not exist

xenial Does not exist

focal
Released (5.13.0-1023.27~20.04.1)
upstream
Released (5.17~rc4)
jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

linux-gkeop-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

kinetic Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux
Launchpad, Ubuntu, Debian
trusty Not vulnerable
(3.11.0-12.19)
upstream
Released (5.17~rc4)
xenial
Released (4.4.0-230.264)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
bionic
Released (4.15.0-177.186)
focal
Released (5.4.0-110.124)
impish
Released (5.13.0-41.46)
jammy Not vulnerable
(5.15.0-23.23)
kinetic Not vulnerable
(5.15.0-25.25)
lunar Not vulnerable
(5.15.0-25.25)
mantic Not vulnerable
(5.15.0-25.25)
Patches:
Introduced by

37a3a533429ef9b3cc9f15a656c19623f0e88df7

Fixed by 75e5b4849b81e19e9efe1654b30d7f3151c33c2c
linux-aws
Launchpad, Ubuntu, Debian
xenial
Released (4.4.0-1146.161)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
bionic
Released (4.15.0-1128.137)
focal
Released (5.4.0-1073.78)
impish
Released (5.13.0-1023.25)
jammy Not vulnerable
(5.15.0-1003.5)
kinetic Not vulnerable
(5.15.0-1004.6)
lunar Not vulnerable
(5.15.0-1004.6)
trusty
Released (4.4.0-1110.116)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (5.17~rc4)
mantic Not vulnerable
(5.15.0-1004.6)
linux-aws-5.3
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
bionic Ignored
(superseded by linux-aws-5.4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
bionic
Released (5.4.0-1075.80~18.04.1)
upstream
Released (5.17~rc4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

linux-aws-5.8
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
bionic Does not exist

focal Ignored
(superseded by linux-aws-5.11)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
xenial
Released (4.15.0-1128.137~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
bionic Does not exist

focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

mantic Does not exist

linux-azure
Launchpad, Ubuntu, Debian
focal
Released (5.4.0-1078.81)
trusty
Released (4.15.0-1138.151~14.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (5.17~rc4)
xenial
Released (4.15.0-1138.151~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
bionic Ignored
(superseded by linux-azure-5.3)
jammy Not vulnerable
(5.15.0-1002.3)
kinetic Not vulnerable
(5.15.0-1003.4)
lunar Not vulnerable
(5.15.0-1003.4)
impish
Released (5.13.0-1023.27)
mantic Not vulnerable
(5.15.0-1003.4)
linux-azure-4.15
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (4.15.0-1138.151)
mantic Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
bionic Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

focal Ignored
(superseded by linux-azure-5.13, was needs-triage)
linux-azure-5.3
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
bionic Ignored
(superseded by linux-azure-5.4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1078.81~18.04.1)
mantic Does not exist

linux-azure-5.8
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
bionic Does not exist

focal Ignored
(superseded by linux-azure-5.11)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
focal
Released (5.4.0-1040.44)
upstream
Released (5.17~rc4)
bionic Does not exist

impish Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

jammy Not vulnerable
(5.15.0-1011.13)
mantic Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (4.15.0-1042.47)
mantic Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
bionic Ignored
(superseded by linux-gcp-5.3)
jammy Not vulnerable
(5.15.0-1003.6)
kinetic Not vulnerable
(5.15.0-1003.6)
lunar Not vulnerable
(5.15.0-1003.6)
trusty Does not exist

focal
Released (5.4.0-1073.78)
impish
Released (5.13.0-1025.30)
xenial
Released (4.15.0-1122.136~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic Not vulnerable
(5.15.0-1003.6)
linux-gcp-4.15
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (4.15.0-1122.136)
mantic Does not exist

linux-gcp-5.11
Launchpad, Ubuntu, Debian
upstream
Released (5.17~rc4)
bionic Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

focal Ignored
(superseded by linux-gcp-5.13, was needs-triage)
linux-aws-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-aws-6.2, was needs-triage)
linux-gcp-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux-riscv-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life, was needs-triage)
linux-azure-fde
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.4.0-1078.81)
impish Does not exist

jammy Needs triage

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
focal
Released (5.13.0-1025.30~20.04.1)
bionic Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-ibm-5.4
Launchpad, Ubuntu, Debian
bionic
Released (5.4.0-1021.23~18.04.1)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-allwinner
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

kinetic Not vulnerable

lunar Not vulnerable

mantic Does not exist

upstream Ignored
(end of life, was needs-triage)
linux-allwinner-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life, was needs-triage)
linux-starfive
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

kinetic Not vulnerable

lunar Not vulnerable

upstream Needs triage

mantic Not vulnerable

linux-starfive-5.19
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

mantic Does not exist

upstream Ignored
(end of life, was needs-triage)
linux-fips
Launchpad, Ubuntu, Debian
xenial Ignored
(end of standard support)
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
mantic Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
xenial Ignored
(end of standard support, was needs-triage)
focal Ignored
(replaced by linux-raspi)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
bionic
Released (4.15.0-1109.116)
mantic Does not exist

linux-snapdragon
Launchpad, Ubuntu, Debian
xenial Ignored
(end of standard support, was needs-triage)
bionic
Released (4.15.0-1127.136)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
mantic Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
xenial
Released (4.15.0-1093.102~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
jammy Not vulnerable
(5.15.0-1002.4)
kinetic Not vulnerable
(5.15.0-1002.4)
lunar Not vulnerable
(5.15.0-1002.4)
trusty Does not exist

upstream
Released (5.17~rc4)
bionic
Released (4.15.0-1093.102)
focal
Released (5.4.0-1071.77)
impish
Released (5.13.0-1028.33)
mantic Not vulnerable
(5.15.0-1002.4)
linux-oem-6.0
Launchpad, Ubuntu, Debian
jammy Not vulnerable
(6.0.0-1006.6)
lunar Does not exist

bionic Does not exist

focal Does not exist

trusty Does not exist

xenial Does not exist

kinetic Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-oem-6.1, was needs-triage)
linux-aws-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux-hwe-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

upstream Ignored
(superseded by linux-hwe-6.5, was needs-triage)
mantic Does not exist

linux-lowlatency-hwe-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

upstream Ignored
(superseded by linux-lowlatency-hwe-6.5, was needs-triage)
mantic Does not exist

linux-ibm-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux-gcp-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux-azure-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux-azure-fde-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

upstream Needs triage

mantic Does not exist

linux-aws-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-aws-5.3)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

focal Ignored
(superseded by linux-aws-5.13, was needs-triage)
linux-aws-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.13.0-1023.25~20.04.1)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-aws-5.15
Launchpad, Ubuntu, Debian
kinetic Does not exist

lunar Does not exist

bionic Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

focal Not vulnerable

mantic Does not exist

linux-azure-5.15
Launchpad, Ubuntu, Debian
kinetic Does not exist

lunar Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mantic Does not exist

linux-azure-5.19
Launchpad, Ubuntu, Debian
lunar Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-6.2, was needs-triage)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.3)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-azure-fde-5.15
Launchpad, Ubuntu, Debian
lunar Does not exist

bionic Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

focal Not vulnerable
(5.15.0-1007.8~20.04.1)
mantic Does not exist

linux-gcp-5.15
Launchpad, Ubuntu, Debian
jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

bionic Does not exist

focal Not vulnerable

mantic Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-gcp-5.4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

bionic
Released (5.4.0-1073.78~18.04.1)
mantic Does not exist

linux-gcp-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-gcp-5.11)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

impish Does not exist

jammy Not vulnerable
(5.15.0-1002.2)
kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Ignored
(end of standard support)
focal
Released (5.4.0-1071.76)
mantic Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

bionic Ignored
(superseded by linux-gke-5.0, was needs-triage)
linux-gke-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(end of standard support)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-gke-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream Ignored
(end of life, was needs-triage)
xenial Does not exist

mantic Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(end of standard support)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

bionic
Released (5.4.0-1071.76~18.04.3)
mantic Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
bionic Does not exist

impish Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

focal
Released (5.4.0-1040.41)
jammy Not vulnerable
(5.15.0-1001.2)
mantic Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

bionic
Released (5.4.0-1040.41~18.04.1)
mantic Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Ignored
(replaced by linux-hwe-5.4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial
Released (4.15.0-177.186~16.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic Does not exist

linux-hwe-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-hwe-5.13)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

focal
Released (5.13.0-41.46~20.04.1)
mantic Does not exist

linux-hwe-5.15
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.15.0-33.34~20.04.1)
kinetic Does not exist

lunar Does not exist

upstream
Released (5.17~rc4)
bionic Does not exist

jammy Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

linux-hwe-5.19
Launchpad, Ubuntu, Debian
lunar Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-hwe-6.2, was needs-triage)
linux-hwe-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

bionic
Released (5.4.0-110.124~18.04.1)
mantic Does not exist

linux-hwe-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-hwe-5.11)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-hwe-5.4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Ignored
(superseded by linux-hwe)
mantic Does not exist

linux-ibm
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.4.0-1021.23)
impish Does not exist

jammy Not vulnerable
(5.15.0-1002.2)
kinetic Not vulnerable
(5.15.0-1002.2)
lunar Not vulnerable
(5.15.0-1002.2)
trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Not vulnerable
(5.15.0-1002.2)
linux-intel-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

focal Ignored
(end of kernel support, was needs-triage)
linux-intel-iotg
Launchpad, Ubuntu, Debian
kinetic Does not exist

lunar Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable
(5.15.0-1004.6)
trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-intel-iotg-5.15
Launchpad, Ubuntu, Debian
kinetic Does not exist

lunar Does not exist

bionic Does not exist

focal
Released (5.15.0-1008.11~20.04.1)
impish Does not exist

jammy Does not exist

trusty Does not exist

xenial Does not exist

upstream
Released (5.17~rc4)
mantic Does not exist

linux-iot
Launchpad, Ubuntu, Debian
upstream Needs triage

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

mantic Does not exist

linux-kvm
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1114.117)
focal
Released (5.4.0-1063.66)
jammy Not vulnerable
(5.15.0-1004.4)
kinetic Not vulnerable
(5.15.0-1004.4)
lunar Not vulnerable
(5.15.0-1004.4)
trusty Does not exist

upstream
Released (5.17~rc4)
xenial
Released (4.4.0-1111.121)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
impish
Released (5.13.0-1022.23)
mantic Does not exist

linux-lowlatency
Launchpad, Ubuntu, Debian
kinetic Not vulnerable
(5.15.0-24.24)
lunar Not vulnerable
(5.15.0-24.24)
bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable
(5.15.0-23.23)
trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Not vulnerable
(5.15.0-24.24)
linux-lowlatency-hwe-5.15
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.15.0-33.34~20.04.1)
kinetic Does not exist

lunar Does not exist

upstream
Released (5.17~rc4)
trusty Does not exist

bionic Does not exist

jammy Does not exist

xenial Does not exist

mantic Does not exist

linux-lowlatency-hwe-5.19
Launchpad, Ubuntu, Debian
lunar Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-lowlatency-hwe-6.2, was needs-triage)
linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty
Released (4.4.0-230.264~14.04.1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oem
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Ignored
(end of standard support)
mantic Does not exist

bionic Ignored
(replaced by linux-hwe-5.4, was needs-triage)
linux-oem-5.10
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-oem-5.13, was needs-triage)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oem-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-oem-5.14, was needs-triage)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.14.0-1027.30)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oem-5.17
Launchpad, Ubuntu, Debian
kinetic Not vulnerable
(5.17.0-1003.3)
lunar Does not exist

bionic Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable
(5.17.0-1003.3)
upstream
Released (5.17~rc4)
mantic Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-oem-5.10, was needs-triage)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oem-6.1
Launchpad, Ubuntu, Debian
lunar Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mantic Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
bionic Ignored
(end of standard support, was needs-triage)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oracle-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-oracle-5.3)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-oracle-5.13, was needs-triage)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.13.0-1028.33~20.04.1)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oracle-5.15
Launchpad, Ubuntu, Debian
kinetic Does not exist

lunar Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mantic Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-oracle-5.4)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

bionic
Released (5.4.0-1071.77~18.04.1)
mantic Does not exist

linux-oracle-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-oracle-5.11)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
bionic Does not exist

jammy Not vulnerable
(5.15.0-1004.4)
kinetic Not vulnerable
(5.15.0-1005.5)
lunar Not vulnerable
(5.15.0-1005.5)
trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

focal
Released (5.4.0-1060.68)
impish
Released (5.13.0-1026.28)
mantic Not vulnerable
(5.15.0-1005.5)
linux-raspi-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

bionic
Released (5.4.0-1060.68~18.04.1)
mantic Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(end of standard support)
focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-riscv-5.8)
impish Ignored
(end of life, was pending)
jammy Not vulnerable
(5.15.0-1005.5)
kinetic Not vulnerable
(5.15.0-1007.7)
lunar Not vulnerable
(5.15.0-1007.7)
trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Not vulnerable
(5.15.0-1007.7)
linux-riscv-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-riscv-5.13, was needs-triage)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-riscv-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

upstream Needs triage

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

linux-riscv-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(superseded by linux-riscv-5.11)
impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

trusty Does not exist

upstream
Released (5.17~rc4)
xenial Does not exist

mantic Does not exist

linux-xilinx-zynqmp
Launchpad, Ubuntu, Debian
upstream Needs triage

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

trusty Does not exist

mantic Does not exist

linux-azure-fde-5.19
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Not vulnerable

kinetic Does not exist

lunar Does not exist

trusty Does not exist

xenial Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-azure-fde-6.2, was needs-triage)
linux-nvidia-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

mantic Does not exist

upstream Needs triage

linux-starfive-6.2
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

mantic Does not exist

upstream Ignored
(superseded by linux-starfive-6.5, was needs-triage)
linux-laptop
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

mantic Not vulnerable

upstream Needs triage

linux-oem-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

mantic Does not exist

upstream Needs triage

linux-hwe-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

mantic Does not exist

upstream Needs triage

linux-lowlatency-hwe-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

lunar Does not exist

mantic Does not exist

upstream Needs triage

linux-riscv-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

mantic Does not exist

upstream Needs triage

linux-starfive-6.5
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Not vulnerable

mantic Does not exist

upstream Needs triage

Severity score breakdown

Parameter Value
Base score 4.6
Attack vector Physical
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H