Your submission was sent successfully! Close

CVE-2020-26939

Published: 2 November 2020

In Legion of the Bouncy Castle BC before 1.61 and BC-FJA before 1.0.1.2, attackers can obtain sensitive information about a private exponent because of Observable Differences in Behavior to Error Inputs. This occurs in org.bouncycastle.crypto.encodings.OAEPEncoding. Sending invalid ciphertext that decrypts to a short payload in the OAEP Decoder could result in the throwing of an early exception, potentially leaking some information about the private exponent of the RSA private key performing the encryption.

Priority

Low

CVSS 3 base score: 5.3

Status

Package Release Status
bouncycastle
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Not vulnerable
(1.61-1)
groovy Not vulnerable

hirsute Not vulnerable

impish Not vulnerable

jammy Not vulnerable

precise Does not exist

trusty Does not exist

upstream
Released (1.61-1)
xenial Ignored
(end of standard support, was needs-triage)