Your submission was sent successfully! Close

CVE-2019-15918

Published: 4 September 2019

An issue was discovered in the Linux kernel before 5.0.10. SMB2_negotiate in fs/cifs/smb2pdu.c has an out-of-bounds read because data structures are incompletely updated after a change from smb30 to smb21.

From the Ubuntu security team

It was discovered that the SMB networking file system implementation in the Linux kernel contained a buffer overread. An attacker could use this to expose sensitive information (kernel memory).

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-66.75)
disco
Released (5.0.0-21.22)
eoan Not vulnerable
(5.2.0-8.9)
focal Not vulnerable
(5.4.0-9.12)
precise Not vulnerable
(3.0.0-12.20)
trusty Not vulnerable
(3.11.0-12.19)
upstream
Released (5.1~rc6)
xenial Not vulnerable
(4.2.0-16.19)
Patches:
Introduced by

9764c02fcbad40001fd3f63558d918e4d519bb75

Fixed by b57a55e2200ede754e4dc9cce4ba9402544b9365
Introduced by

d5c7076b772ad7dcdb92303397b36aee8fa0d25d

Fixed by b57a55e2200ede754e4dc9cce4ba9402544b9365
linux-aws
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1052.54)
disco Ignored
(was pending \[5.0.0-1011.12\] now end-of-life)
eoan Not vulnerable
(5.0.0-1011.12)
focal Not vulnerable
(5.4.0-1005.5)
precise Does not exist

trusty Not vulnerable
(4.4.0-1002.2)
upstream
Released (5.1~rc6)
xenial Not vulnerable
(4.4.0-1001.10)
linux-aws-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-1021.24~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial
Released (4.15.0-1052.54~16.04.1)
linux-azure
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-1014.14~18.04.1)
disco
Released (5.0.0-1012.12)
eoan Not vulnerable
(5.0.0-1012.12)
focal Not vulnerable
(5.4.0-1006.6)
precise Does not exist

trusty
Released (4.15.0-1061.66~14.04.1)
upstream
Released (5.1~rc6)
xenial
Released (4.15.0-1061.66)
linux-azure-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.3.0-1007.8~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-1014.14~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial
Released (4.15.0-1061.66)
linux-gcp
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-1020.20~18.04.1)
disco
Released (5.0.0-1011.11)
eoan Not vulnerable
(5.0.0-1011.11)
focal Not vulnerable
(5.4.0-1005.5)
precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial
Released (4.15.0-1047.50)
linux-gcp-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.3.0-1008.9~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-1020.20~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1046.49)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-1011.11~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.3.0-1011.12~18.04.1)
eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-23.24~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial
Released (4.15.0-66.75~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(was pending \[5.3.0-19.20~18.04.2\] now end-of-life)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial
Released (4.15.0-66.75~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1048.48)
disco
Released (5.0.0-1011.12)
eoan Not vulnerable
(5.0.0-1011.12)
focal Not vulnerable
(5.4.0-1004.4)
precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Not vulnerable
(4.4.0-1004.9)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

precise Not vulnerable
(3.13.0-24.46~precise1)
trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Not vulnerable
(4.4.0-13.29~14.04.1)
upstream
Released (5.1~rc6)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1059.68)
disco Ignored
(reached end-of-life)
eoan
Released (4.15.0-1059.68)
focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Ignored
(was needs-triage now end-of-life)
linux-oem-5.6
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Not vulnerable
(5.4.0-1002.4)
precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-1015.16)
disco Ignored
(was pending \[5.0.0-1015.16\] now end-of-life)
eoan
Released (5.0.0-1018.20)
focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1027.30)
disco
Released (5.0.0-1004.8)
eoan Not vulnerable
(5.3.0-1002.2)
focal Not vulnerable
(5.4.0-1005.5)
precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial
Released (4.15.0-1027.30~16.04.1)
linux-oracle-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-1007.12~18.04.1)
disco Does not exist

eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.3.0-1011.12~18.04.1)
eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1049.53)
disco Ignored
(was pending \[5.0.0-1013.13\] now end-of-life)
eoan Not vulnerable
(5.0.0-1013.13)
focal Not vulnerable
(5.4.0-1004.4)
precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Not vulnerable
(4.2.0-1013.19)
linux-raspi2-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.3.0-1017.19~18.04.1)
eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Does not exist

linux-snapdragon
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1066.73)
disco
Released (5.0.0-1017.18)
eoan Does not exist

focal Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.1~rc6)
xenial Not vulnerable
(4.4.0-1012.12)