Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

USN-5855-1: ImageMagick vulnerabilities

9 February 2023

Several security issues were fixed in ImageMagick.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Releases

Packages

  • imagemagick - Image manipulation programs and library

Details

It was discovered that ImageMagick incorrectly handled certain PNG images.
If a user or automated system were tricked into opening a specially crafted
PNG file, an attacker could use this issue to cause ImageMagick to stop
responding, resulting in a denial of service, or possibly obtain the
contents of arbitrary files by including them into images.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-5855-2: libimage-magick-perl, libmagickwand-6.q16hdri-dev, libimage-magick-q16-perl, imagemagick-6-common, libmagick++-6.q16hdri-8, imagemagick-6.q16, libmagickcore-6.q16-6, libimage-magick-q16hdri-perl, libmagick++-6.q16-8, libmagickcore-6.q16-dev, imagemagick-common, libmagickcore-6.q16-6-extra, libmagickwand-dev, libmagickcore-6-headers, imagemagick-doc, libmagick++-6.q16-dev, libmagickcore-6-arch-config, libmagick++-6.q16hdri-dev, imagemagick-6.q16hdri, libmagickwand-6.q16-6, libmagick++-6-headers, imagemagick, libmagickwand-6-headers, imagemagick-6-doc, libmagickcore-dev, perlmagick, libmagickcore-6.q16hdri-6-extra, libmagick++-dev, libmagickwand-6.q16hdri-6, libmagickcore-6.q16hdri-dev, libmagickwand-6.q16-dev, libmagickcore-6.q16hdri-6
  • USN-5855-4: libimage-magick-perl, libimage-magick-q16-perl, imagemagick-6.q16, libmagick++5, libmagickwand5, libmagickcore-6.q16-2, libmagickcore-6.q16-dev, imagemagick-common, libmagickwand-dev, libmagickcore-6-headers, libmagickcore5, imagemagick-doc, libmagick++-6.q16-5v5, libmagick++-6.q16-dev, libmagickcore-6-arch-config, libmagickwand-6.q16-2, libmagick++-6-headers, imagemagick, libmagickwand-6-headers, libmagickcore-dev, libmagickcore5-extra, perlmagick, libmagick++-dev, libmagickcore-6.q16-2-extra, libmagickwand-6.q16-dev