Your submission was sent successfully! Close

USN-5559-1: Moment.js vulnerabilities

10 August 2022

Several security issues were fixed in Moment.js.

Releases

Packages

  • node-moment - Work with dates in JavaScript (Node.js module)

Details

It was discovered that Moment.js incorrectly handled certain input paths. An
attacker could possibly use this issue to cause a loss of integrity by
changing the correct path to one of their choice. (CVE-2022-24785)

It was discovered that Moment.js incorrectly handled certain input. An attacker
could possibly use this issue to cause a denial of service. (CVE-2022-31129)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 22.04
Ubuntu 20.04
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.