Your submission was sent successfully! Close

USN-5212-1: Apache HTTP Server vulnerabilities

6 January 2022

Several security issues were fixed in Apache HTTP Server.

Releases

Packages

Details

It was discovered that the Apache HTTP Server incorrectly handled certain
forward proxy requests. A remote attacker could use this issue to cause
the server to crash, resulting in a denial of service, or possibly perform
a Server Side Request Forgery attack. (CVE-2021-44224)

It was discovered that the Apache HTTP Server Lua module incorrectly
handled memory in the multipart parser. A remote attacker could use this
issue to cause the server to crash, resulting in a denial of service, or
possibly execute arbitrary code. (CVE-2021-44790)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 21.10
Ubuntu 21.04
Ubuntu 20.04
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-5212-2: libapache2-mod-macro, apache2-utils, apache2-mpm-prefork, apache2-suexec-pristine, apache2.2-bin, apache2-suexec, libapache2-mod-proxy-html, apache2, apache2-bin, apache2-mpm-itk, apache2-doc, apache2-mpm-worker, apache2-dev, apache2-data, apache2-mpm-event, apache2-suexec-custom