Your submission was sent successfully! Close

USN-501-1: jasper vulnerability

21 August 2007

jasper vulnerability

Releases

Details

It was discovered that Jasper did not correctly handle corrupted JPEG2000
images. By tricking a user into opening a specially crafted JPG, a
remote attacker could cause the application using libjasper to crash,
resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
  • libjasper-1.701-1 - 1.701.0-2ubuntu0.7.04
Ubuntu 6.10
  • libjasper-1.701-1 - 1.701.0-2ubuntu0.6.10
Ubuntu 6.06
  • libjasper-1.701-1 - 1.701.0-2ubuntu0.6.06

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

Related notices