USN-4968-2: LZ4 vulnerability

31 May 2021

LZ4 could be made to crash or run programs if it opened a specially crafted file.

Releases

Packages

  • lz4 - Extremely fast compression algorithm

Details

USN-4968-1 fixed a vulnerability in LZ4. This update provides
the corresponding update for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that LZ4 incorrectly handled certain memory operations.
If a user or automated system were tricked into uncompressing a specially-
crafted LZ4 file, a remote attacker could use this issue to cause LZ4 to
crash, resulting in a denial of service, or possibly execute arbitrary
code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.

References

Related notices

  • USN-4968-1: liblz4-dev, liblz4-tool, lz4, liblz4-1