USN-4905-1: X.Org X Server vulnerability

13 April 2021

X.Org X Server could be made to crash or run programs if it received specially crafted input.

Releases

Packages

Details

Jan-Niklas Sohn discovered that the X.Org X Server incorrectly handled
certain lengths of XInput extension ChangeFeedbackControl requests. An
attacker could use this issue to cause the server to crash, resulting in a
denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.10
Ubuntu 20.04
Ubuntu 18.04
Ubuntu 16.04

After a standard system update you need to reboot your computer to make all
the necessary changes.

References

Related notices

  • USN-4905-2: xorg-server, xdmx, xserver-xephyr, xserver-xorg-xmir, xorg-server-source, xvfb, xserver-xorg-core-udeb, xdmx-tools, xserver-xorg-dev, xserver-common, xserver-xorg-core, xnest