Your submission was sent successfully! Close

USN-4549-1: ImageMagick vulnerabilities

28 September 2020

ImageMagick could be made to crash if it opened a specially crafted file.

Releases

Packages

  • imagemagick - Image manipulation programs and library

Details

It was discovered that ImageMagick incorrectly handled certain specially
crafted image files. If a user or automated system using ImageMagick were
tricked into opening a specially crafted image, an attacker could exploit
this to cause a denial of service or other unspecified impact.
(CVE-2019-19948, CVE-2019-19949)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-4670-1: libmagickcore-6.q16-3, imagemagick-6.q16, imagemagick-6.q16hdri, libmagickwand-6.q16-6, libmagick++-6.q16hdri-7, imagemagick-6-doc, libmagick++-6.q16hdri-8, libmagick++-6.q16-dev, libmagickcore-6.q16hdri-3-extra, libimage-magick-q16hdri-perl, libmagickcore-6.q16hdri-3, libmagick++-6.q16-7, libmagickcore-6.q16-6, perlmagick, libmagickcore-6.q16-6-extra, libmagickcore-dev, libmagickwand-6.q16-2, libmagickcore-6.q16hdri-6-extra, libmagickcore-6.q16hdri-dev, libmagickwand-6.q16hdri-6, imagemagick-6-common, libmagick++-6.q16-5v5, libmagickwand-6.q16-3, imagemagick-common, libmagick++-dev, libmagickcore-6-headers, libmagickwand-6.q16-dev, libimage-magick-perl, libmagick++-6-headers, libmagick++-6.q16-8, libmagickcore-6.q16-dev, imagemagick, imagemagick-doc, libmagickwand-6.q16hdri-3, libmagickcore-6.q16-2, libmagickwand-6.q16hdri-dev, libmagickwand-6-headers, libimage-magick-q16-perl, libmagick++-6.q16hdri-dev, libmagickcore-6-arch-config, libmagickcore-6.q16-3-extra, libmagickcore-6.q16hdri-6, libmagickwand-dev, libmagickcore-6.q16-2-extra