USN-4514-1: libproxy vulnerability

17 September 2020

libproxy could be made to crash if it received a specially crafted PAC file.

Releases

Packages

  • libproxy - automatic proxy configuration management library

Details

It was discovered that libproxy incorrectly handled certain PAC files.
An attacker could possibly use this issue to cause a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.04
Ubuntu 18.04
Ubuntu 16.04

After a standard system update you need to restart your session to make
all the necessary changes.

References