Your submission was sent successfully! Close

USN-4194-1: postgresql-common vulnerability

14 November 2019

postgresql-common could be made to create arbitrary directories.

Releases

Packages

Details

Rich Mirch discovered that the postgresql-common pg_ctlcluster script
incorrectly handled directory creation. A local attacker could possibly use
this issue to escalate privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
Ubuntu 19.04
Ubuntu 18.04
Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

References

Related notices

  • USN-4194-2: postgresql-client-common, postgresql, postgresql-contrib, postgresql-common, postgresql-doc, postgresql-server-dev-all, postgresql-client