Your submission was sent successfully! Close

USN-4123-1: npm/fstream vulnerability

05 September 2019

npm/fstream could be made to overwrite files.

Releases

Packages

  • node-fstream - Advanced filesystem streaming tools for Node.js

Details

It was discovered that npm/fstream incorrectly handled certain crafted
tarballs. An attacker could use this vulnerability to write aritrary files to
the filesystem.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.

References