Your submission was sent successfully! Close

USN-4015-1: DBus vulnerability

11 June 2019

DBus could allow unintended access to services.

Releases

Packages

  • dbus - simple interprocess messaging system

Details

Joe Vennix discovered that DBus incorrectly handled DBUS_COOKIE_SHA1
authentication. A local attacker could possibly use this issue to bypass
authentication and connect to DBus servers with elevated privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.10
Ubuntu 18.04
Ubuntu 16.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

Related notices

  • USN-4015-2: dbus, libdbus-1-3, dbus-1-doc, libdbus-1-dev, dbus-x11