Your submission was sent successfully! Close

USN-386-1: ImageMagick vulnerability

28 November 2006

ImageMagick vulnerability

Releases

Details

Daniel Kobras discovered multiple buffer overflows in ImageMagick's SGI
file format decoder. By tricking a user or an automated system into
processing a specially crafted SGI image, this could be exploited to
execute arbitrary code with the user's privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06
  • libmagick9 - 6:6.2.4.5-0.6ubuntu0.4
Ubuntu 5.10
  • libmagick6 - 6:6.2.3.4-1ubuntu1.5

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References