USN-3842-1: CUPS vulnerability

10 December 2018

CUPS could be made to expose sensitive information.

Releases

Packages

  • cups - Common UNIX Printing System(tm)

Details

Jann Horn discovered that CUPS incorrectly handled session cookie
randomness. A remote attacker could possibly use this issue to perform
cross-site request forgery (CSRF) attacks.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10
Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.

References