USN-374-1: wvWare vulnerability

01 November 2006

wvWare vulnerability

Releases

Details

An integer overflow was discovered in the DOC file parser of the wv
library. By tricking a user into opening a specially crafted MSWord
(.DOC) file, remote attackers could execute arbitrary code with the
user's privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
  • libwv-1.2-1 - 1.2.1-2ubuntu0.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References