USN-3684-1: Perl vulnerability

13 June 2018

Perl could be made to overwrite arbitrary files if it received a specially crafted archive file.

Releases

Packages

  • perl - Practical Extraction and Report Language

Details

It was discovered that Perl incorrectly handled certain archive files.
An attacker could possibly use this to overwrite arbitrary files.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04
Ubuntu 17.10
Ubuntu 16.04
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.

References

Related notices