USN-3342-1: Linux kernel vulnerabilities

29 June 2017

Several security issues were fixed in the Linux kernel.

Releases

Packages

Details

USN 3326-1 fixed a vulnerability in the Linux kernel. However, that
fix introduced regressions for some Java applications. This update
addresses the issue. We apologize for the inconvenience.

It was discovered that a use-after-free flaw existed in the filesystem
encryption subsystem in the Linux kernel. A local attacker could use this
to cause a denial of service (system crash). (CVE-2017-7374)

Roee Hay discovered that the parallel port printer driver in the Linux
kernel did not properly bounds check passed arguments. A local attacker
with write access to the kernel command line arguments could use this to
execute arbitrary code. (CVE-2017-1000363)

Ingo Molnar discovered that the VideoCore DRM driver in the Linux kernel
did not return an error after detecting certain overflows. A local attacker
could exploit this issue to cause a denial of service (OOPS).
(CVE-2017-5577)

Li Qiang discovered that an integer overflow vulnerability existed in the
Direct Rendering Manager (DRM) driver for VMWare devices in the Linux
kernel. A local attacker could use this to cause a denial of service
(system crash) or possibly execute arbitrary code. (CVE-2017-7294)

It was discovered that a double-free vulnerability existed in the IPv4
stack of the Linux kernel. An attacker could use this to cause a denial of
service (system crash). (CVE-2017-8890)

Andrey Konovalov discovered an IPv6 out-of-bounds read error in the Linux
kernel's IPv6 stack. A local attacker could cause a denial of service or
potentially other unspecified problems. (CVE-2017-9074)

Andrey Konovalov discovered a flaw in the handling of inheritance in the
Linux kernel's IPv6 stack. A local user could exploit this issue to cause a
denial of service or possibly other unspecified problems. (CVE-2017-9075)

It was discovered that dccp v6 in the Linux kernel mishandled inheritance.
A local attacker could exploit this issue to cause a denial of service or
potentially other unspecified problems. (CVE-2017-9076)

It was discovered that the transmission control protocol (tcp) v6 in the
Linux kernel mishandled inheritance. A local attacker could exploit this
issue to cause a denial of service or potentially other unspecified
problems. (CVE-2017-9077)

It was discovered that the IPv6 stack in the Linux kernel was performing
its over write consistency check after the data was actually overwritten. A
local attacker could exploit this flaw to cause a denial of service (system
crash). (CVE-2017-9242)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.10

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-3291-3: linux-image-4.4.0-78-powerpc64-smp, linux-lts-xenial, linux-image-4.4.0-78-generic-lpae, linux-image-extra-4.4.0-78-generic, linux-image-4.4.0-78-powerpc-e500mc, linux-image-4.4.0-78-powerpc64-emb, linux-image-4.4.0-78-generic, linux-image-4.4.0-78-powerpc-smp, linux-image-4.4.0-78-lowlatency
  • USN-3265-2: linux-image-4.4.0-75-generic, linux-image-extra-4.4.0-75-generic, linux-image-4.4.0-75-powerpc-smp, linux-image-4.4.0-75-powerpc64-smp, linux-lts-xenial, linux-image-4.4.0-75-lowlatency, linux-image-4.4.0-75-generic-lpae, linux-image-4.4.0-75-powerpc-e500mc, linux-image-4.4.0-75-powerpc64-emb
  • USN-3344-1: linux-aws, linux-image-4.4.0-1063-snapdragon, linux-image-4.4.0-83-powerpc-smp, linux-raspi2, linux-image-4.4.0-83-lowlatency, linux-image-extra-4.4.0-83-generic, linux, linux-image-4.4.0-83-generic, linux-image-4.4.0-83-generic-lpae, linux-image-4.4.0-83-powerpc64-emb, linux-snapdragon, linux-image-4.4.0-1018-gke, linux-image-4.4.0-1061-raspi2, linux-image-4.4.0-83-powerpc-e500mc, linux-image-4.4.0-83-powerpc64-smp, linux-image-4.4.0-1022-aws, linux-gke, linux-image-extra-4.4.0-1018-gke
  • USN-3291-1: linux-image-4.4.0-78-powerpc64-smp, linux-image-4.4.0-78-generic-lpae, linux-image-extra-4.4.0-78-generic, linux, linux-image-4.4.0-78-powerpc-e500mc, linux-image-4.4.0-78-powerpc64-emb, linux-image-4.4.0-78-generic, linux-image-4.4.0-78-powerpc-smp, linux-image-4.4.0-78-lowlatency
  • USN-3265-1: linux-image-4.4.0-75-generic, linux-aws, linux-image-extra-4.4.0-75-generic, linux-image-4.4.0-75-powerpc-smp, linux-image-4.4.0-75-powerpc64-smp, linux-raspi2, linux-image-4.4.0-1057-snapdragon, linux-image-4.4.0-75-lowlatency, linux, linux-image-4.4.0-75-generic-lpae, linux-image-4.4.0-1016-aws, linux-image-4.4.0-75-powerpc-e500mc, linux-image-4.4.0-75-powerpc64-emb, linux-snapdragon, linux-image-4.4.0-1054-raspi2, linux-image-extra-4.4.0-1012-gke, linux-image-4.4.0-1012-gke, linux-gke
  • USN-3345-1: linux-image-4.10.0-26-lowlatency, linux-raspi2, linux-image-generic, linux-image-4.10.0-26-generic-lpae, linux-image-lowlatency, linux-image-4.10.0-1010-raspi2, linux, linux-image-generic-lpae, linux-image-4.10.0-26-generic, linux-image-raspi2
  • USN-3342-2: linux-image-4.8.0-58-lowlatency, linux-hwe, linux-image-extra-4.8.0-58-generic, linux-image-4.8.0-58-generic, linux-image-4.8.0-58-generic-lpae
  • USN-3343-2: linux-image-generic-lts-trusty, linux-lts-trusty, linux-image-generic-lpae-lts-trusty, linux-image-3.13.0-123-generic-lpae, linux-image-3.13.0-123-generic
  • USN-3293-1: linux-raspi2, linux-image-generic, linux-image-4.10.0-21-generic, linux-image-4.10.0-1005-raspi2, linux-image-lowlatency, linux-image-4.10.0-21-generic-lpae, linux, linux-image-4.10.0-21-lowlatency, linux-image-generic-lpae, linux-image-raspi2
  • USN-3360-2: linux-image-3.13.0-125-generic-lpae, linux-image-generic-lts-trusty, linux-image-3.13.0-125-generic, linux-lts-trusty, linux-image-generic-lpae-lts-trusty
  • USN-3343-1: linux-image-3.13.0-123-powerpc-e500, linux-image-3.13.0-123-powerpc64-smp, linux, linux-image-extra-3.13.0-123-generic, linux-image-3.13.0-123-generic-lpae, linux-image-3.13.0-123-powerpc-e500mc, linux-image-3.13.0-123-generic, linux-image-3.13.0-123-powerpc-smp, linux-image-3.13.0-123-powerpc64-emb, linux-image-3.13.0-123-lowlatency
  • USN-3344-2: linux-image-4.4.0-83-lowlatency, linux-lts-xenial, linux-image-extra-4.4.0-83-generic, linux-image-4.4.0-83-generic-lpae, linux-image-4.4.0-83-generic, linux-image-4.4.0-83-powerpc64-emb, linux-image-4.4.0-83-powerpc-e500mc, linux-image-4.4.0-83-powerpc-smp, linux-image-4.4.0-83-powerpc64-smp
  • USN-3291-2: linux-image-4.4.0-1055-raspi2, linux-aws, linux-raspi2, linux-image-extra-4.4.0-1013-gke, linux-snapdragon, linux-image-4.4.0-1017-aws, linux-image-4.4.0-1013-gke, linux-image-4.4.0-1058-snapdragon, linux-gke