Your submission was sent successfully! Close

USN-3156-2: APT regression

17 December 2016

USN-3156-1 introduced a regression in unattended-upgrades that may require manual intervention to repair.

Releases

Packages

  • apt - Advanced front-end for dpkg

Details

USN-3156-1 fixed vulnerabilities in APT. It also caused a bug in
unattended-upgrades on that may require manual intervention to repair.

Users on Ubuntu 16.10 should run the following commands at a
terminal:

sudo dpkg --configure --pending
sudo apt-get -f install

This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

Jann Horn discovered that APT incorrectly handled InRelease files.
If a remote attacker were able to perform a machine-in-the-middle attack,
this flaw could potentially be used to install altered packages.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.10

After a standard system update you should run the following commands
to make all the necessary changes:
sudo dpkg --configure --pending
sudo apt-get -f install