USN-2911-1: Linux kernel vulnerability

22 February 2016

The system could be made to crash under certain conditions.

Releases

Packages

  • linux - Linux kernel

Details

It was discovered that the Linux kernel keyring subsystem contained a race
between read and revoke operations. A local attacker could use this to
cause a denial of service (system crash).

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References

Related notices

  • USN-2888-1: linux-image-3.16.0-60-lowlatency, linux-image-3.16.0-60-generic-lpae, linux-image-3.16.0-60-powerpc-e500mc, linux-lts-utopic, linux-image-3.16.0-60-powerpc64-emb, linux-image-3.16.0-60-powerpc-smp, linux-image-3.16.0-60-powerpc64-smp, linux-image-3.16.0-60-generic
  • USN-2890-1: linux-image-4.2.0-27-lowlatency, linux-image-4.2.0-27-powerpc-smp, linux-image-4.2.0-27-powerpc64-smp, linux-image-4.2.0-27-generic-lpae, linux-image-4.2.0-27-powerpc64-emb, linux-image-4.2.0-27-powerpc-e500mc, linux-image-4.2.0-27-generic, linux
  • USN-2890-2: linux-image-4.2.0-27-lowlatency, linux-image-4.2.0-27-powerpc-smp, linux-image-4.2.0-27-powerpc64-smp, linux-lts-wily, linux-image-4.2.0-27-generic-lpae, linux-image-4.2.0-27-powerpc64-emb, linux-image-4.2.0-27-powerpc-e500mc, linux-image-4.2.0-27-generic
  • USN-2890-3: linux-raspi2, linux-image-4.2.0-1022-raspi2
  • USN-2907-1: linux-image-3.13.0-79-powerpc64-emb, linux-image-3.13.0-79-powerpc-e500, linux-image-3.13.0-79-powerpc-smp, linux-image-3.13.0-79-powerpc-e500mc, linux-image-3.13.0-79-generic, linux-image-3.13.0-79-lowlatency, linux-image-3.13.0-79-generic-lpae, linux-image-3.13.0-79-powerpc64-smp, linux
  • USN-2907-2: linux-image-3.13.0-79-generic, linux-lts-trusty, linux-image-3.13.0-79-generic-lpae
  • USN-2910-1: linux-image-3.19.0-51-powerpc64-smp, linux-image-3.19.0-51-lowlatency, linux-image-3.19.0-51-powerpc-smp, linux-image-3.19.0-51-powerpc64-emb, linux-lts-vivid, linux-image-3.19.0-51-generic, linux-image-3.19.0-51-generic-lpae, linux-image-3.19.0-51-powerpc-e500mc
  • USN-2911-2: linux-image-3.2.0-1477-omap4, linux-ti-omap4