Your submission was sent successfully! Close

USN-2450-1: strongSwan vulnerability

5 January 2015

strongSwan could be made to crash if it received specially crafted network traffic.

Releases

Packages

Details

Mike Daskalakis discovered that strongSwan incorrectly handled IKEv2
payloads that contained the Diffie-Hellman group 1025. A remote attacker
could use this issue to cause the IKE daemon to crash, resulting in a
denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.

References