USN-2237-1: Linux kernel (Quantal HWE) vulnerability

05 June 2014

The system could be made to crash or run programs as an administrator.

Releases

Packages

Details

Pinkie Pie discovered a flaw in the Linux kernel's futex subsystem. An
unprivileged local user could exploit this flaw to cause a denial of
service (system crash) or gain administrative privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

Related notices

  • USN-2233-1: linux-image-2.6.32-61-virtual, linux-image-2.6.32-61-ia64, linux-image-2.6.32-61-lpia, linux-image-2.6.32-61-generic-pae, linux-image-2.6.32-61-powerpc, linux-image-2.6.32-61-preempt, linux, linux-image-2.6.32-61-powerpc64-smp, linux-image-2.6.32-61-powerpc-smp, linux-image-2.6.32-61-386, linux-image-2.6.32-61-versatile, linux-image-2.6.32-61-generic, linux-image-2.6.32-61-server, linux-image-2.6.32-61-sparc64, linux-image-2.6.32-61-sparc64-smp
  • USN-2238-1: linux-image-3.8.0-42-generic, linux-lts-raring
  • USN-2234-1: linux-image-2.6.32-365-ec2, linux-ec2
  • USN-2241-1: linux-image-3.11.0-23-generic-lpae, linux, linux-image-3.11.0-23-generic
  • USN-2240-1: linux-image-3.13.0-29-generic, linux, linux-image-3.13.0-29-lowlatency, linux-image-3.13.0-29-powerpc64-emb, linux-image-3.13.0-29-powerpc-e500mc, linux-image-3.13.0-29-powerpc-smp, linux-image-3.13.0-29-generic-lpae, linux-image-3.13.0-29-powerpc64-smp, linux-image-3.13.0-29-powerpc-e500
  • USN-2239-1: linux-image-3.11.0-23-generic-lpae, linux-lts-saucy, linux-image-3.11.0-23-generic
  • USN-2235-1: linux-image-3.2.0-64-highbank, linux-image-3.2.0-64-omap, linux, linux-image-3.2.0-64-virtual, linux-image-3.2.0-64-generic, linux-image-3.2.0-64-generic-pae, linux-image-3.2.0-64-powerpc-smp, linux-image-3.2.0-64-powerpc64-smp
  • USN-2236-1: linux-ti-omap4, linux-image-3.2.0-1449-omap4
  • USN-2260-1: linux-image-3.13.0-30-generic-lpae, linux-lts-trusty, linux-image-3.13.0-30-generic