Your submission was sent successfully! Close

USN-2104-1: LXC vulnerability

12 February 2014

LXC would allow unintended access to the host, bypassing intended confinement.

Releases

Packages

  • lxc - Linux Containers userspace tools

Details

Florian Sagar discovered that the LXC sshd template set incorrect mount
permissions. An attacker could possibly use this flaw to cause privilege
escalation on the host.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 13.10

After a standard system update you need to recreate LXC containers created
with the sshd template to make all the necessary changes.

References