USN-1468-1: Linux kernel vulnerability

12 June 2012

The system could be made to crash or run programs as an administrator.

Releases

Packages

Details

Schacher Raindel discovered a flaw in the Linux kernel's memory handling
when hugetlb is enabled. An unprivileged local attacker could exploit this
flaw to cause a denial of service and potentially gain higher privileges.

References

Related notices

  • USN-1470-1: linux-image-2.6.38-15-generic, linux-image-2.6.38-15-generic-pae, linux-lts-backport-natty, linux-image-2.6.38-15-server, linux-image-2.6.38-15-virtual
  • USN-1457-1: linux-image-2.6.38-15-powerpc-smp, linux-image-2.6.38-15-generic, linux-image-2.6.38-15-generic-pae, linux-image-2.6.38-15-powerpc, linux-image-2.6.38-15-server, linux-image-2.6.38-15-omap, linux-image-2.6.38-15-virtual, linux, linux-image-2.6.38-15-powerpc64-smp, linux-image-2.6.38-15-versatile
  • USN-1476-1: linux-ti-omap4, linux-image-3.0.0-1211-omap4
  • USN-1471-1: linux-image-3.0.0-21-server, linux-image-3.0.0-21-virtual, linux-lts-backport-oneiric, linux-image-3.0.0-21-generic-pae, linux-image-3.0.0-21-generic
  • USN-1472-1: linux-image-3.0.0-21-omap, linux-image-3.0.0-21-server, linux-image-3.0.0-21-powerpc, linux, linux-image-3.0.0-21-powerpc-smp, linux-image-3.0.0-21-virtual, linux-image-3.0.0-21-powerpc64-smp, linux-image-3.0.0-21-generic-pae, linux-image-3.0.0-21-generic
  • USN-1474-1: linux-image-3.2.0-1414-omap4, linux-ti-omap4
  • USN-1473-1: linux-image-3.2.0-25-generic, linux-image-3.2.0-25-omap, linux-image-3.2.0-25-highbank, linux, linux-image-3.2.0-25-powerpc-smp, linux-image-3.2.0-25-generic-pae, linux-image-3.2.0-25-virtual, linux-image-3.2.0-25-powerpc64-smp
  • USN-1469-1: linux-ec2, linux-image-2.6.32-345-ec2