Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-39573

Published: 1 July 2024

Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Notes

AuthorNote
mdeslaur
Same commit as one of the ones listed in CVE-2024-38473

Priority

Medium

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
bionic Needs triage

focal
Released (2.4.41-4ubuntu3.19)
jammy
Released (2.4.52-1ubuntu4.10)
mantic
Released (2.4.57-2ubuntu2.5)
noble
Released (2.4.58-1ubuntu8.2)
trusty Needs triage

upstream
Released (2.4.60-1)
xenial Needs triage

Patches:
upstream: https://github.com/apache/httpd/commit/9494aa8d52e3c263bc0413b77ac8a73b0d524388
upstream: https://svn.apache.org/viewvc?view=revision&revision=1918600
upstream: https://github.com/apache/httpd/commit/93aec0e3ca451bcc97f6d91c14d5399d13a73365