Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-38474

Published: 1 July 2024

Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.

Priority

Medium

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
bionic Needs triage

focal
Released (2.4.41-4ubuntu3.19)
jammy
Released (2.4.52-1ubuntu4.10)
mantic
Released (2.4.57-2ubuntu2.5)
noble
Released (2.4.58-1ubuntu8.2)
trusty Needs triage

upstream
Released (2.4.60-1)
xenial Needs triage

Patches:
upstream: https://svn.apache.org/viewvc?view=revision&revision=1918561
upstream: https://github.com/apache/httpd/commit/1feb5e04a4f7b5f3f13cd40f9635144319dcf24a