Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-28219

Published: 3 April 2024

In _imagingcms.c in Pillow before 10.3.0, a buffer overflow exists because strcpy is used instead of strncpy.

Priority

Medium

Status

Package Release Status
pillow
Launchpad, Ubuntu, Debian
bionic Needed

focal Needed

jammy Needed

mantic Needed

trusty Needed

upstream
Released (10.3.0)
xenial Needed

Patches:
upstream: https://github.com/python-pillow/Pillow/commit/2a93aba5cfcf6e241ab4f9392c13e3b74032c061
pillow-python2
Launchpad, Ubuntu, Debian
focal Needed

jammy Does not exist

mantic Does not exist

upstream Needs triage