Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-27834

Published: 14 May 2024

The issue was addressed with improved checks. This issue is fixed in iOS 17.5 and iPadOS 17.5, tvOS 17.5, Safari 17.5, watchOS 10.5, macOS Sonoma 14.5. An attacker with arbitrary read and write capability may be able to bypass Pointer Authentication.

Notes

AuthorNote
jdstrand
webkit receives limited support. For details, see
https://wiki.ubuntu.com/SecurityTeam/FAQ#webkit
webkit in Ubuntu uses the JavaScriptCore (JSC) engine, not V8
mdeslaur
It is no longer possible to build new webkit2gtk versions on
focal and earlier. Marking as ignored.

Priority

Medium

Status

Package Release Status
qtwebkit-opensource-src
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

mantic Ignored

noble Ignored

upstream Ignored

xenial Ignored

qtwebkit-source
Launchpad, Ubuntu, Debian
bionic Ignored

focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

xenial Ignored

webkit2gtk
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy
Released (2.44.2-0ubuntu0.22.04.1)
mantic
Released (2.44.2-0ubuntu0.23.10.1)
noble
Released (2.44.2-0ubuntu0.24.04.1)
upstream
Released (2.44.2)
xenial Ignored

webkitgtk
Launchpad, Ubuntu, Debian
bionic Ignored

focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

xenial Ignored

wpewebkit
Launchpad, Ubuntu, Debian
focal Ignored

jammy Ignored

mantic Does not exist

noble Does not exist

upstream Needs triage