Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-27459

Published: 8 July 2024

The interactive service in OpenVPN 2.6.9 and earlier allows an attacker to send data causing a stack overflow which can be used to execute arbitrary code with more privileges.

Notes

AuthorNote
mdeslaur
Windows-specific issue

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
openvpn
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Ignored
(end of life, was needs-triage)
noble Not vulnerable
(Windows only)
trusty Not vulnerable
(Windows only)
upstream Not vulnerable
(debian: Only affects Windows)
xenial Not vulnerable
(Windows only)

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H