Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-7104

Published: 29 December 2023

A vulnerability was found in SQLite SQLite3 up to 3.43.0 and classified as critical. This issue affects the function sessionReadRecord of the file ext/session/sqlite3session.c of the component make alltest Handler. The manipulation leads to heap-based buffer overflow. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-248999.

Priority

Medium

Cvss 3 Severity Score

7.3

Score breakdown

Status

Package Release Status
sqlite
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

jammy Needs triage

lunar Does not exist

mantic Does not exist

trusty Needs triage

upstream Needs triage

xenial Needs triage

sqlite3
Launchpad, Ubuntu, Debian
bionic Needed

focal
Released (3.31.1-4ubuntu0.6)
jammy
Released (3.37.2-2ubuntu0.3)
lunar
Released (3.40.1-1ubuntu0.1)
mantic
Released (3.42.0-1ubuntu0.1)
trusty Not vulnerable
(code not present)
upstream
Released (3.44.2-1)
xenial Not vulnerable
(code not present)
Patches:
upstream: https://sqlite.org/src/info/0e4e7a05c4204b47

Severity score breakdown

Parameter Value
Base score 7.3
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality Low
Integrity impact Low
Availability impact Low
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L