Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-6516

Published: 13 February 2024

To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are asynchronous: a small chunk of memory pointing to the cache element that can be cleaned up is first allocated and then queued for later processing. It was discovered that if the resolver is continuously processing query patterns triggering this type of cache-database maintenance, `named` may not be able to handle the cleanup events in a timely manner. This in turn enables the list of queued cleanup events to grow infinitely large over time, allowing the configured `max-cache-size` limit to be significantly exceeded. This issue affects BIND 9 versions 9.16.0 through 9.16.45 and 9.16.8-S1 through 9.16.45-S1.

Notes

AuthorNote
alexmurray
As of isc-dhcp-4.4.3-1, isc-dhcp vendors bind9 libs
mdeslaur
only affects 9.16.x

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
bind9
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal
Released (1:9.16.48-0ubuntu0.20.04.1)
jammy Not vulnerable
(1:9.18.18-0ubuntu0.22.04.1)
mantic Not vulnerable
(1:9.18.18-0ubuntu2)
trusty Not vulnerable

upstream
Released (9.16.48,9.18.24,9.19.21)
xenial Not vulnerable

Patches:
upstream: https://ftp.isc.org/isc/bind9/9.16.48/patches/0004-CVE-2023-6516.patch
bind9-libs
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
mantic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

isc-dhcp
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
mantic Not vulnerable
(code not present)
trusty Not vulnerable
(code not present)
upstream Needs triage

xenial Not vulnerable
(code not present)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H