Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-47038

Published: 25 November 2023

A vulnerability was found in perl 5.30.0 through 5.38.0. This issue occurs when a crafted regular expression is compiled by perl, which can allow an attacker controlled byte buffer overflow in a heap allocated buffer.

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
perl
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal
Released (5.30.0-9ubuntu0.5)
jammy
Released (5.34.0-3ubuntu1.3)
lunar
Released (5.36.0-7ubuntu0.23.04.2)
mantic
Released (5.36.0-9ubuntu1.1)
noble
Released (5.36.0-10ubuntu1)
trusty Not vulnerable
(code not present)
upstream Needs triage

xenial Not vulnerable
(code not present)
Patches:
upstream: https://github.com/Perl/perl5/commit/ff1f9f59360afeebd6f75ca1502f5c3ebf077da3
perl6
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

jammy Does not exist

lunar Does not exist

mantic Does not exist

noble Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)
raku
Launchpad, Ubuntu, Debian
bionic Ignored
(end of standard support)
focal Does not exist

jammy Does not exist

lunar Ignored
(end of life, was needs-triage)
mantic Ignored
(end of life, was needs-triage)
noble Needs triage

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H