Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-46751

Published: 7 December 2023

An issue was discovered in the function gdev_prn_open_printer_seekable() in Artifex Ghostscript through 10.02.0 allows remote attackers to crash the application via a dangling pointer.

Notes

AuthorNote
mdeslaur
introduced by:
https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=e1a3956f252404f07d93be47f7845b23e4a2c4de

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Not vulnerable

bionic Not vulnerable

focal Not vulnerable
(9.50~dfsg-5ubuntu4.11)
jammy
Released (9.55.0~dfsg1-0ubuntu5.6)
lunar
Released (10.0.0~dfsg1-0ubuntu1.5)
mantic
Released (10.01.2~dfsg1-0ubuntu2.2)
upstream
Released (10.02.1~dfsg-1)
Patches:
upstream: https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=dcdbc595c13c9d11d235702dff46bb74c80f7698
upstream: https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=5d2da96e81c7455338302c71a291088a8396245a (10.02.1)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H