Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!Close

CVE-2023-4504

Published: 20 September 2023

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

Priority

Medium

Cvss 3 Severity Score

0.0

Score breakdown

Status

Package Release Status
cups
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
upstream Needs triage

focal
Released (2.3.1-9ubuntu1.6)
jammy
Released (2.4.1op1-1ubuntu4.7)
lunar
Released (2.4.2-3ubuntu2.5)
bionic
Released (2.2.7-1ubuntu2.10+esm2)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (2.1.3-4ubuntu0.11+esm4)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic
Released (2.4.6-0ubuntu2)
libppd
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Needs triage

bionic Needs triage

focal Needs triage

jammy Needs triage

upstream Needs triage

lunar
Released (2:2.0~rc1-0ubuntu1.2)
mantic
Released (2:2.0~rc1-0ubuntu4)

Severity score breakdown

Parameter Value
Base score 0.0
Attack vector Local
Attack complexity Low
Privileges required High
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact None
Vector CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:N