Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-4057

Published: 2 August 2023

Memory safety bugs present in Firefox 115, Firefox ESR 115.0, and Thunderbird 115.0. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 116, Firefox ESR < 115.1, and Thunderbird < 115.1.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
mdeslaur
starting with Ubuntu 22.04, the firefox package is just a script
that installs the Firefox snap

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
focal Not vulnerable
(116.0+build2-0ubuntu0.20.04.2)
jammy Not vulnerable

lunar Not vulnerable

upstream
Released (116.0-1)
mantic Not vulnerable

thunderbird
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
focal
Released (1:115.3.1+build1-0ubuntu0.20.04.1)
jammy
Released (1:115.3.1+build1-0ubuntu0.22.04.2)
upstream
Released (102.14,115.1)
lunar
Released (1:115.3.1+build1-0ubuntu0.23.04.1)
mantic
Released (1:115.2.0+build1-0ubuntu1)
mozjs38
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Needs triage

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

mozjs52
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Needs triage

focal Needs triage

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

mozjs68
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Needs triage

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

mozjs78
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Needs triage

upstream Needs triage

mantic Does not exist

lunar Ignored
(end of life, was needs-triage)
mozjs91
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Needs triage

lunar Does not exist

upstream Needs triage

mantic Does not exist

mozjs102
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Needs triage

upstream Needs triage

mantic Needs triage

lunar Ignored
(end of life, was needs-triage)

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H