Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-40267

Published: 11 August 2023

GitPython before 3.1.32 does not block insecure non-multi options in clone and clone_from. NOTE: this issue exists because of an incomplete fix for CVE-2022-24439.

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
python-git
Launchpad, Ubuntu, Debian
upstream Needs triage

bionic
Released (2.1.8-1ubuntu0.1~esm2)
Available with Ubuntu Pro
focal
Released (3.0.7-1ubuntu0.1~esm2)
Available with Ubuntu Pro
jammy
Released (3.1.24-1ubuntu0.1~esm2)
Available with Ubuntu Pro
lunar
Released (3.1.30-1ubuntu0.23.04.1)
trusty
Released (0.3.2~RC1-3ubuntu0.1~esm2)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (1.0.1+git137-gc8b8379-2.1ubuntu0.1~esm2)
Available with Ubuntu Pro
mantic Needs triage

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H