Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2023-37203

Published: 5 July 2023

Insufficient validation in the Drag and Drop API in conjunction with social engineering, may have allowed an attacker to trick end-users into creating a shortcut to local system files. This could have been leveraged to execute arbitrary code. This vulnerability affects Firefox < 115.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
mdeslaur
starting with Ubuntu 22.04, the firefox package is just a script
that installs the Firefox snap

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
jammy Not vulnerable
(code not present)
kinetic Ignored
(end of life, was needs-triage)
lunar Not vulnerable
(code not present)
upstream
Released (115.0-1)
focal
Released (115.0+build2-0ubuntu0.20.04.3)
thunderbird
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
focal Not vulnerable

jammy Not vulnerable

kinetic Ignored
(end of life, was needed)
lunar Not vulnerable

upstream Needs triage

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H