Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-24580

Published: 14 February 2023

An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0 before 4.0.10, and 4.1 before 4.1.7. Passing certain inputs (e.g., an excessive number of parts) to multipart forms could result in too many open files or memory exhaustion, and provided a potential vector for a denial-of-service attack.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
python-django
Launchpad, Ubuntu, Debian
lunar
Released (3:3.2.18-1)
trusty Needed

bionic
Released (1:1.11.11-1ubuntu1.20)
focal
Released (2:2.2.12-1ubuntu0.16)
jammy
Released (2:3.2.12-2ubuntu1.5)
kinetic
Released (3:3.2.15-1ubuntu1.2)
upstream
Released (4.1.7,4.0.10,3.2.18)
xenial Needed

mantic
Released (3:3.2.18-1)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H