Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-48565

Published: 22 August 2023

An XML External Entity (XXE) issue was discovered in Python through 3.9.1. The plistlib module no longer accepts entity declarations in XML plist files to avoid XML vulnerabilities.

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
python
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

python2.7
Launchpad, Ubuntu, Debian
focal Needs triage

jammy Needs triage

lunar Does not exist

upstream Needs triage

bionic
Released (2.7.17-1~18.04ubuntu1.13+esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
trusty
Released (2.7.6-8ubuntu0.6+esm16)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (2.7.12-1ubuntu0~16.04.18+esm6)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic Does not exist

python3.4
Launchpad, Ubuntu, Debian
trusty Needs triage

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

python3.5
Launchpad, Ubuntu, Debian
trusty Needs triage

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

xenial
Released (3.5.2-2ubuntu0~16.04.13+esm9)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic Does not exist

python3.6
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Needs triage

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

python3.7
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Needs triage

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

python3.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Needs triage

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

focal Not vulnerable
(3.8.10-0ubuntu1~20.04.9)
Patches:
upstream: https://github.com/python/cpython/commit/65894cac0835cb8f469f649e20aa1be8bf89f5ae
python3.9
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

focal
Released (3.9.5-3~20.04.1)
mantic Does not exist

python3.10
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

upstream Needs triage

jammy Not vulnerable
(3.10.0-2)
mantic Does not exist

python3.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Needs triage

upstream Needs triage

lunar Not vulnerable
(3.11.0~rc2-1)
mantic Not vulnerable
(3.11.2-6)
python3.12
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Not vulnerable
(3.12.0~a7-1)

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H