Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-48564

Published: 22 August 2023

read_ints in plistlib.py in Python through 3.9.1 is vulnerable to a potential DoS attack via CPU and RAM exhaustion when processing malformed Apple Property List files in binary format.

Priority

Medium

Cvss 3 Severity Score

6.5

Score breakdown

Status

Package Release Status
python
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Ignored
(end of standard support)
bionic Ignored
(end of standard support)
focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

python2.7
Launchpad, Ubuntu, Debian
focal Needs triage

jammy Needs triage

lunar Does not exist

upstream Needs triage

trusty
Released (2.7.6-8ubuntu0.6+esm18)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
mantic Does not exist

bionic
Released (2.7.17-1~18.04ubuntu1.13+esm4)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (2.7.12-1ubuntu0~16.04.18+esm9)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
python3.4
Launchpad, Ubuntu, Debian
xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

trusty Needed

python3.5
Launchpad, Ubuntu, Debian
trusty Needs triage

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

xenial
Released (3.5.2-2ubuntu0~16.04.13+esm12)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
python3.6
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

bionic
Released (3.6.9-1~18.04ubuntu1.13+esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
python3.7
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Needs triage

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

python3.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Needs triage

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

focal Not vulnerable
(3.8.10-0ubuntu1~20.04.8)
python3.9
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Needs triage

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

python3.10
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

lunar Does not exist

upstream Needs triage

mantic Does not exist

jammy Not vulnerable
(3.10.12-1~22.04.2)
python3.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Needs triage

upstream Needs triage

lunar Not vulnerable
(3.11.4-1~23.04)
mantic Not vulnerable
(3.11.6-3)
python3.12
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Does not exist

lunar Does not exist

upstream Needs triage

mantic Not vulnerable
(3.12.0-1)

Severity score breakdown

Parameter Value
Base score 6.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H