Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-44940

Published: 19 December 2022

Patchelf v0.9 was discovered to contain an out-of-bounds read via the function modifyRPath at src/patchelf.cc.

Notes

AuthorNote
eslerm
version 0.10 and earlier require extensive backport

Priority

Medium

Cvss 3 Severity Score

9.1

Score breakdown

Status

Package Release Status
patchelf
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
focal Needs triage

jammy
Released (0.14.3-1ubuntu0.1~esm1)
Available with Ubuntu Pro
kinetic
Released (0.14.3-1ubuntu0.1)
upstream
Released (0.16.0)
xenial Needed

bionic Needed

mantic Needs triage

lunar Ignored
(end of life, was needs-triage)
Patches:
upstream: https://github.com/NixOS/patchelf/commit/b751eeb137d71765b3c35c4210c1c3b64dcd3a32

Severity score breakdown

Parameter Value
Base score 9.1
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H