Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-3705

Published: 26 October 2022

A vulnerability was found in vim and classified as problematic. Affected by this issue is the function qf_update_buffer of the file quickfix.c of the component autocmd Handler. The manipulation leads to use after free. The attack may be launched remotely. Upgrading to version 9.0.0805 is able to address this issue. The name of the patch is d0fab10ed2a86698937e3c3fed2f10bd9bb5e731. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-212324.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
vim
Launchpad, Ubuntu, Debian
kinetic Ignored
(end of life, was needs-triage)
trusty Ignored
(changes too intrusive)
upstream Needs triage

xenial Ignored
(changes too intrusive)
lunar Not vulnerable
(2:9.0.1000-4ubuntu3.1)
bionic Ignored
(changes too intrusive)
focal
Released (2:8.1.2269-1ubuntu5.18)
jammy
Released (2:8.2.3995-1ubuntu2.12)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity High
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H