Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-36320

Published: 27 July 2022

Mozilla developers and the Mozilla Fuzzing Team reported memory safety bugs present in Firefox 102. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 103.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
mdeslaur
starting with Ubuntu 22.04, the firefox package is just a script
that installs the Firefox snap

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
mozjs78
Launchpad, Ubuntu, Debian
focal Does not exist

kinetic Ignored
(end of life, was needs-triage)
bionic Does not exist

jammy Needs triage

trusty Does not exist

upstream Needs triage

xenial Does not exist

mantic Does not exist

lunar Ignored
(end of life, was needs-triage)
mozjs91
Launchpad, Ubuntu, Debian
xenial Does not exist

bionic Does not exist

focal Does not exist

jammy Needs triage

trusty Does not exist

upstream Needs triage

kinetic Does not exist

lunar Does not exist

mantic Does not exist

thunderbird
Launchpad, Ubuntu, Debian
kinetic Ignored
(end of life, was needed)
focal
Released (1:102.2.2+build1-0ubuntu0.20.04.1)
jammy
Released (1:102.2.2+build1-0ubuntu0.22.04.1)
lunar Not vulnerable
(1:102.3.3+build1-0ubuntu1)
upstream
Released (102.1)
trusty Does not exist

bionic Ignored
(end of standard support, was needed)
xenial Ignored
(end of standard support)
mantic Not vulnerable
(1:102.3.3+build1-0ubuntu1)
mozjs38
Launchpad, Ubuntu, Debian
upstream Needs triage

xenial Does not exist

bionic Needs triage

focal Does not exist

jammy Does not exist

trusty Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

mozjs52
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

mozjs68
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needs triage

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

firefox
Launchpad, Ubuntu, Debian
jammy Not vulnerable
(code not present)
trusty Does not exist

xenial Ignored
(end of standard support)
bionic
Released (103.0+build1-0ubuntu0.18.04.1)
focal
Released (103.0+build1-0ubuntu0.20.04.1)
upstream
Released (103)
kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
mantic Not vulnerable
(code not present)

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H